THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


Bonjour à tous,

J'ai installé Thelia sur mon hébergement pro OVH en décompressant le dossier téléchargé ici dans la racine de mon site.
J'ai créé ma db et ai inscrit les bons id pour s'y connecter dans: thelia\local\config\database.yml.

De mon navigateur je vais sur http://mondomaine.fr/thelia/web/install/index.php, et j'obtiens ceci:


Whoops, looks like something went wrong.

2/2 PropelException: Unable to execute SELECT statement [SELECT config.ID, config.NAME, config.VALUE, config.SECURED, config.HIDDEN, config.CREATED_AT, config.UPDATED_AT FROM `config` WHERE config.NAME=:p1 LIMIT 1]

    in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/Criteria.php line 2442
    at Criteria->doSelect(object(ConnectionWrapper)) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php line 1821
    at ModelCriteria->doSelect(object(ConnectionWrapper)) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php line 1000
    at ModelCriteria->findOne(null) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php line 1176
    at ModelCriteria->findOneBy('Name', 'tlog_level')
    at call_user_func_array(array(object(ConfigQuery), 'findOneBy'), array('Name', 'tlog_level')) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php line 2027
    at ModelCriteria->__call('findOneByName', array('tlog_level')) in /home/mondomaine/www/thelia/core/lib/Thelia/Model/ConfigQuery.php line 37
    at ConfigQuery->findOneByName('tlog_level') in /home/mondomaine/www/thelia/core/lib/Thelia/Model/ConfigQuery.php line 37
    at ConfigQuery::read('tlog_level', '100') in /home/mondomaine/www/thelia/core/lib/Thelia/Log/Tlog.php line 136
    at Tlog->init() in /home/mondomaine/www/thelia/core/lib/Thelia/Log/Tlog.php line 110
    at Tlog::getInstance() in /home/mondomaine/www/thelia/core/lib/Thelia/Core/Thelia.php line 74
    at Thelia->initPropel() in /home/mondomaine/www/thelia/core/lib/Thelia/Core/Thelia.php line 55
    at Thelia->init() in /home/mondomaine/www/thelia/core/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/Kernel.php line 92
    at Kernel->__construct('install', true) in /home/mondomaine/www/thelia/web/install/bootstrap.php line 16
    at include('/home/mondomaine/www/thelia/web/install/bootstrap.php') in /home/mondomaine/www/thelia/web/install/header.php line 16
    at include('/home/mondomaine/www/thelia/web/install/header.php') in /home/mondomaine/www/thelia/web/install/index.php line 16

1/2 PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'mondomainethelia.config' doesn't exist

    in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/Connection/StatementWrapper.php line 196
    at PDOStatement->execute(null) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/Connection/StatementWrapper.php line 196
    at StatementWrapper->execute() in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/Criteria.php line 2436
    at Criteria->doSelect(object(ConnectionWrapper)) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php line 1821
    at ModelCriteria->doSelect(object(ConnectionWrapper)) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php line 1000
    at ModelCriteria->findOne(null) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php line 1176
    at ModelCriteria->findOneBy('Name', 'tlog_level')
    at call_user_func_array(array(object(ConfigQuery), 'findOneBy'), array('Name', 'tlog_level')) in /home/mondomaine/www/thelia/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php line 2027
    at ModelCriteria->__call('findOneByName', array('tlog_level')) in /home/mondomaine/www/thelia/core/lib/Thelia/Model/ConfigQuery.php line 37
    at ConfigQuery->findOneByName('tlog_level') in /home/mondomaine/www/thelia/core/lib/Thelia/Model/ConfigQuery.php line 37
    at ConfigQuery::read('tlog_level', '100') in /home/mondomaine/www/thelia/core/lib/Thelia/Log/Tlog.php line 136
    at Tlog->init() in /home/mondomaine/www/thelia/core/lib/Thelia/Log/Tlog.php line 110
    at Tlog::getInstance() in /home/mondomaine/www/thelia/core/lib/Thelia/Core/Thelia.php line 74
    at Thelia->initPropel() in /home/mondomaine/www/thelia/core/lib/Thelia/Core/Thelia.php line 55
    at Thelia->init() in /home/mondomaine/www/thelia/core/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/Kernel.php line 92
    at Kernel->__construct('install', true) in /home/mondomaine/www/thelia/web/install/bootstrap.php line 16
    at include('/home/mondomaine/www/thelia/web/install/bootstrap.php') in /home/mondomaine/www/thelia/web/install/header.php line 16
    at include('/home/mondomaine/www/thelia/web/install/header.php') in /home/mondomaine/www/thelia/web/install/index.php line 16


Je ne comprend rien à tout ce que cela peut bien vouloir dire...
J'ai besoin d'aide SVP sad

Last edited by Frugi (12-10-2014 16:55:56)

Offline


J'ai créé une table qui s'appelle mondomainethelia dans ma bd via phpmyadmin mais ça ne change rien...

Offline


Bon j'ai supprimé mon fichier database.yml et rafraichit la page, du coup j'ai pu tomber sur l'installation normale de Thélia.
Tout s'est bien passé, mais à la fin lorsque l'installation me dirige vers http://mon domaine.fr/thelia/web/index.php/admin, je tombe sur une page blanche. Tout le répertoire http://mondomaine.fr/thelia/web/ dirige vers des pages blanches...

Offline


Page blanche = erreur PHP. Va voir tes logs d'erreur Apache, ou démarre Thelia en mode développement. Une recherche sur le forum te dira comment faire.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Merci pour ta réponse!

Mais je ne sais même pas ce qu'est Apache ...

Et aucun résultat pour la recherche "mode développement" sur le forum sad

Offline


Quelqu'un pourrait m'expliquuuuer? sad

Offline


Pour utiliser Thelia en mode développement sur un serveur distant, ouvrir le fichier web/index_dev.php, et ajouter ton adresse IP à la liste :

// List of allowed IP
$trustedIp = array(
  '::1',
  '127.0.0.1',
  'ton.adresse.ip'
);

Ensuite, accède à ta boutique avec  http://mondomaine.fr/thelia/web/index_dev.php

Tu verras alors l'erreur éventuelle dans ton navigateur.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Nickel, merci beaucoup!

Ça m'a donné la même erreur que sur ce post: http://doc.thelia.fr/forum/viewtopic.php?id=10393

Du coup j'ai mis un # dans mon fichier .ovhconfig et tout est rentré dans l'ordre!

Encore un grand merci smile

Online


Bonjour,
j'ai le même problème que vous mais j'ai pas bien compris votre solution.
Merci de me donner plus de détails