THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 MAMP THELIA1 THELIA2

(13-05-2014 18:20:02)


Bonjour,
je sèche.... j'ai besoin de développer des sites en thelia2, par ailleurs, d'autres refontes de templates sont à refaire sur d'autres sites  en thelia1. Donc, besoin de pouvoir faire fonctionner les deux, si pas en même temps, au moins en alternance.
Pour faire fonctionner thelia2 , j'installe la mise à jour de Mamp (3.0.5). Résultat : thelia2 sans soucis, thelia1 gros bordel.

j'ai essayé :
1/ installation des sites qui fonctionnaient en thelia1 : page blanche
2/installation des install propres vierges , téléchargées sur grigoinne et github une version patché pour fonctionner en php 5.4 : page blanche, ou "Echec de selection de la base de données."
3/Différentes bidouilles sur mamp dégotées au travers de google pour sélectionner le php que l'on veut faire fonctionner.... ben ça change pas....que dalle.
Quelqu'un aurait-il une idée lumineuse et extraordinaire ?
Merci !


MAC OS LION MAMP
Quand on veut vraiment, on peut toujours.

  • manu
  • faï tot petar miladiu

Offline

#2 Re: MAMP THELIA1 THELIA2

(14-05-2014 08:07:22)


Bonjour,

la dernière version de Thelia 1 fonctionne jusqu'en php 5.5 du coup tu ne devrais pas avoir de soucis particulier.

Si tu as une page = erreur qui sera loggé dans les logs d'erreur apache. Avec ça tu auras déjà plus d'informations (et nous aussi)


http://doc.thelia.net/
http://thelia.net/modules
http://raynaud.io
PGP public Key : 0xC6E546A6

Offline

#3 Re: MAMP THELIA1 THELIA2

(14-05-2014 12:24:23)


J'ai ceci :

[error] [client ::1] client denied by server configuration: /Applications/MAMP/htdocs/.DS_Store

et dans ce DS.store

Bud1ia_154
thelia_1543Ilocblobˇˇˇˇˇˇ
thelia_1543 2Ilocblobˇˇˇˇˇˇ
thelia_2.0.1Ilocblobˇˇˇˇˇˇ
@Ä @Ä @Ä @EDSDB `Ä @Ä @Ä @

fonctionne correctement thelia2, thelia2.1, wordpress et avec bidouille 1.5.4.3

Sur une install de 1543 je reste sur la page http://localhost:8888/thelia1543/install/configuration.php
avec le message
Le serveur de base de données n'est pas accessible.
la base est cependant créée mais ne supporte pas les chiffres dans le nom, mais pas de page type données de connexion on passe direct à configuration.php
je corrige les données dans config_thelia
je passe donc maintenant à http://localhost:8888/thelia1543/install/configuration.php correctement
et là tout roule

par contre page blanche pour thelia 1.5.3.4
je recommence
sur une install 1534 ( une dont j'ai besoin pour mettre à jour le site ) à l'install  ou j'ai directement http://localhost:8888/thelia_1.5.3.4/install/configuration.php?err=1&utilisateur=&nomadmin=&emailcontact=&nomsite=&urlsite=
et les erreurs ci-dessus
ou alors http://localhost:8888/artipierre/install/configuration.php
et page blanche. la base est correstement créée ou remplie ( j'ai essayé les deux)
Je précise qu'à chaque fois je ferme et nettoie les cookies du navigateur

Last edited by aleyjo (14-05-2014 13:42:38)


MAC OS LION MAMP
Quand on veut vraiment, on peut toujours.

  • manu
  • faï tot petar miladiu

Offline

#4 Re: MAMP THELIA1 THELIA2

(14-05-2014 17:48:18)


Le fichier .DS_Store n'est pas important et peut être ignoré, c'est ton mac qui le génère.

Donc ton problème vient du faire d'avoir des chiffres dans le nom de la base de données ? Par exemple si tu l'appelle thelia_1543 ça plante et si tu l'appelles thelia ça ne plante pas ? C'est ça ?


http://doc.thelia.net/
http://thelia.net/modules
http://raynaud.io
PGP public Key : 0xC6E546A6

Offline

#5 Re: MAMP THELIA1 THELIA2

(14-05-2014 17:57:03)


curieusement , oui, avant ça ne me faisait pas ça avec l'ancienne version de mamp, là ça me créé les bases de données mais ça me squizze les chiffres. alors en reprenant les connexions du config la version 1543 fonctionne ( sans mettre de chiffre, le nouveau mamp est visiblement littéraire), mais j'arrive pas à faire fonctionner la version dont j'ai besoin la 153. je comprends pas pourquoi


MAC OS LION MAMP
Quand on veut vraiment, on peut toujours.