THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


Bonjour à tous,

je tente d'installer le module PayPlug (modules.thelia.net/payplug-payment-module.html) sur mon Thelia, mais sans succès.

Lorsque je télécharge le zip et que je le dépose dans mon back-office, j'ai un message d'erreur qui me stipule qu'il faut une version de Thelia en 2.5 ou supérieure.
Le truc c'est que, sauf erreur de ma part, la 2.5 n'est pas sortie (sauf en alpha) donc c'est un peu étrange non ?

Le message exact :
Donnée manquante ou non valide : [Le fichier Zip du module] Le module n'est pas valide : Le module PayPlugModule-main nécessite Thelia 2.5.0 ou plus récent

Ma version actuelle de Thelia est la 2.3.4 (oui elle date un poil), mais est-ce nécessaire de mettre à jour pour la 2.4 sachant que le module m'exige 2.5 ?

Je vois sur le forum que d'autres utilisateurs semblent l'utiliser, comment ont-ils fait pour l'installer ? (je suis sur un mutu, donc l'installation via Composer va être peu envisageable)

Merci d'avance !

Offline


salut

prend la version d'avant
https://github.com/thelia-modules/PayPl … e/releases

par contre je me demande si ce module n'est pas a installé avec composer

Offline


Hello,

merci pour ta réponse, par contre les versions précédentes ne semblent pas être disponibles autrement qu'en source code (ou alors j'ai loupé un truc dans GitHub) ce qui semble confirmer que l'install ne se fait que via Composer. Je me trompe ?

Du coup là sur mon mutu ça va être chaud...
Je n'ai aucune connaissance sur l'installation via composer ça se tente sur un mutu OVH ?

Merci

Offline


Au temps pour moi ça semble marcher, je dois mettre à jour sur une 2.4 mais ça semble impec !
Merci pour la réponse !

Offline


selon ta version tu as accès en ssh au serveur d'ovh, après tu te connectes et tu fait ce que tu veux à distance, attention c'est de la ligne de commande. mais je te conseille fortement de mettre le nez dedans, car beaucoup de module on finit en installation composer, car ça installe automatiquement les dépendances à la bonne version

Online


Généralement, sur les modules, la branche "master" est celle réservée à la 2.4, et la branche "main" à la 2.5

L'installation doit être réalisée avec composer pour que les dépendances soient elles aussi installées

Il y a un un guide chez OVH pour pouvoir utiliser composer sur un hébergement mutualisé : https://docs.ovh.com/fr/hosting/install … mutualises


OpenStudio Toulouse

Offline


Merci à tous pour vos réponses, je vais me pencher là-dessus :-)

Offline


roadster31 wrote:

Il y a un un guide chez OVH pour pouvoir utiliser composer sur un hébergement mutualisé : https://docs.ovh.com/fr/hosting/install … mutualises

Ah merci ! Je me posais la question pour le module de paiement Stripe. En local, on l'installe avec Composer, mais sur un mutualisé, comment fait-on ? Grand merci, encore une fois !