THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


Bonjour,

J'ai migré début aout une installation Thelia 2.3.5 sur un serveur en 7.2 et je constate que cela ne semble finalement pas compatible bien que la doc dise le contraire (je sais qu'on en est à 2.4.x mais j'avais vérifié ça avant la sortie de la 2.4).

Erreur lorsque l'on essaye d'éditer un produit:

ContextErrorException in InstancePoolTrait.php line 33: Warning: count(): Parameter must be an array or an object that implements Countable

Erreur typique de compatibilité PHP au delà de 7.1 ... J'envisage de mettre à jour en 2.4 ou de re-déplacer le site ... étant donné l'urgence (pour le client), 2 questions:
- 2.4 est vraiment compatible 7.2 ?
- est-ce une mise à jour à risque, complexe ?

Merci. Pierre.

Offline


Bonjour,

Apparemment j'avais regardé de travers, je lis en d'autres endroits (posts Roadster et Github) que Thelia 2.3 est compatible 7.1 max ...

Pierre

Last edited by pierrot (26-08-2020 08:35:27)

Offline


Bonjour,
si cela peut t'aider je fait tourner Thelia 2.4 avec 7.2.22


Toujours en forme,
La différence entre le possible et l’impossible, c’est la volonté, et le  temps ...
Oui mais... ça c'est avec la meilleure volonté du Monde,
Et elle est, des fois, difficile à tenir... Thelia 2.4.2

Offline


Bonjour,
Ok merci ! oui c'est bien ce qui est indiqué dans la doc, ça doit marcher en 7.2 avec 2.4 :-)
Pierre

Offline


Bonjour à tous,
je te confirme que cela fonctionne bien jusqu'à php  7.2.22
Serveur Windows
Ma dernière version en ligne fonctionnelle parfaitement.
Si cela peu t'aider..
Portez vous bien


Toujours en forme,
La différence entre le possible et l’impossible, c’est la volonté, et le  temps ...
Oui mais... ça c'est avec la meilleure volonté du Monde,
Et elle est, des fois, difficile à tenir... Thelia 2.4.2