THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 Module pour Payline

(14-05-2019 05:09:55)


Bonjour,
Je suis en train de faire un module pour Thelia 2 pour pouvoir payer avec payline.

J'ai déja fait toute la partie pour configurer le module dans le back office.
Je suis en train de créer l'action au moment du paiement.

J'utilise la librairy fourni : https://github.com/PaylineByMonext/payl … master.zip

Par contre j'ai une erreur au moment ou j'envoie le paiement en utilisant leur librairy, comme quoi une class qu'ils utilisent n'est pas trouver.
La classe en question est SoapVar. Effectivement elle n'est pas fournis dans le SDK mais je n'arrive pas à la trouver ailleurs.

J'ai essayé en activant l’extension php soapclient mais cela ne change rien. Avez vous déja eu ce problème ?

Merci par avance.

Pour info la doc de l'api est ici : https://payline.atlassian.net/wiki/spac … 18/SDK+PHP

Offline

#2 Re: Module pour Payline

(14-05-2019 08:18:19)


SoapVar est une classe de L'extension SOAP de PHP.

A ma connaissance, il n'existe pas d'extension "soapclient". As-tu bien activé l'extension "soap" de PHP (extension=php_soap.dll). ?

Dans un phpinfo(), tu vois bien l'extension soap comme ceci :

download


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#3 Re: Module pour Payline

(14-05-2019 08:26:19)


Bonjour,
Oui j'ai regardé les deux extensions sont bien bien activé.

Offline

#4 Re: Module pour Payline

(14-05-2019 11:13:36)


Comment tu as installé "leur librairie" ? Avec composer ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#5 Re: Module pour Payline

(14-05-2019 13:45:16)


J'ai utilisé la commande suivante pour ajouter la derniere version de leur sdk

composer require monext/payline-sdk

Tout c'est bien installé.
Dans mon module est ce que je dois faire un use core/vendor/monex/payline ....ou c'est pas la peine ?

Last edited by katsuya (14-05-2019 14:13:30)

Offline

#6 Re: Module pour Payline

(13-08-2019 11:47:20)


Bonjour Katsuya,

Je cherche un module Payline pour T2. As-tu finalisé le tien ?
Merci d'avance
Gildart