THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 Mise à jour 2.3.4 en 2.3.5

(08-08-2019 11:26:53)


Bonjour,

Sur un Thelia disons "vierge", aucune modification de template pour l'instant, je souhaite faire la mise à jour 2.3.4 vers 2.3.5.
Je relis (disons pour la millième fois) la méthode proposée ici http://doc.thelia.net/en/documentation/ … anced.html après avoir lu celle lu proposée ici http://doc.thelia.net/en/documentation/ … index.html sachant qu'à priori j'avais installé en utilisant composer.
Bref dans advanced.html il est dit que l'on peut faire direct:

$ sh change-version.sh 2.3.1 (or 2.2.3)

donc évidemment j'essaye ça en remplaçant 2.3.1 par 2.3.5 soit

$ sh change-version.sh 2.3.5

mais bien sûr ça ne marche pas ce serait trop facile, j'ai un message "Can't open change-version.sh" ce qui me surprend à moitié car perso je ne vois ce fichier nulle part dans mon installation ... il devrait se trouver ou à priori ?

Merci d'avance aux bonnes âmes pas en vacances ...
Pierre

Offline


change-version.sh n'est disponible que sur   une installation thelia-project.

Tu n'as pas dû installer initialement un thelia-project.

On peut voir le contenu de ton composer.json ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Bonsoir,

Oui je pense qu'effectivement j'ai utilisé les instructions de la page installation/index et non pas celle de installation/advanced ... ou je vois maintenant effectivement la difference, thelia/thelia vs thelia/thelia-project même si je ne sais pas exactement quelles en sont les conséquences :-)

Mon composer.json

{
    "name": "thelia/thelia",
    "description": "Thelia is an ecommerce CMS.",
    "license": "LGPL-3.0+",
    "homepage": "http://thelia.net/",
    "keywords": [
        "ecommerce",
        "cms",
        "cms ecommerce",
        "ecommerce cms"
    ],
    "support": {
        "forum": "http://thelia.net/forum",
        "wiki": "http://doc.thelia.net"
    },
    "repositories": [
        {
            "type": "vcs",
            "url": "https://github.com/thelia/Propel2"
        }
    ],
    "require": {
        "php": ">=5.5",
        "ircmaxell/password-compat": "1.0.*",
        "psr/log": "1.0",
        "symfony/config": "2.8.*",
        "symfony/console": "2.8.*",
        "symfony/dependency-injection": "2.8.*",
        "symfony/event-dispatcher": "2.8.*",
        "symfony/http-kernel": "2.8.*",
        "symfony/routing": "2.8.*",
        "symfony/filesystem": "2.8.*",
        "symfony/yaml": "2.8.*",
        "symfony/translation": "2.8.*",
        "symfony-cmf/routing": "1.3.*",
        "symfony/validator": "2.8.*",
        "symfony/options-resolver": "2.8.*",
        "symfony/security": "2.8.*",
        "symfony/expression-language": "2.8.*",
        "symfony/process": "2.8.*",
        "symfony/dom-crawler": "2.8.*",
        "symfony/property-access": "2.8.*",
        "symfony/serializer": "2.8.*",
        "ensepar/html2pdf": "1.0.1",
        "symfony/finder": "2.8.*",
        "symfony/browser-kit": "2.8.*",
        "symfony/http-foundation": "2.8.*",
        "symfony/form": "2.8.*",
        "symfony/class-loader": "2.8.*",
        "symfony/icu": "1.0",
        "stack/builder": "1.0.*",
        "thelia/currency-converter": "~1.0",
        "doctrine/cache": "1.5.*",
        "kriswallsmith/assetic": "1.3.*",
        "ptachoire/cssembed": "1.0.*",
        "simplepie/simplepie": "1.3.*",
        "imagine/imagine": "0.6.*",
        "swiftmailer/swiftmailer": "5.4.*",
        "oyejorge/less.php": "1.7.*",
        "michelf/php-markdown": "1.6.*",
        "smarty/smarty": "3.1.20",
        "ramsey/array_column": "~1.1",
        "propel/propel": "dev-thelia-2.3",
        "commerceguys/addressing": "0.8.*",
        "symfony/cache": "~3.1.0"
    },
    "require-dev": {
        "fzaninotto/faker": "1.5.*",
        "thelia/hooktest-module": "~1.1",
        "thelia/hooktest-template": "~1.1",
        "phpunit/phpunit": "4.8.*"
    },
    "minimum-stability": "stable",
    "config": {
        "vendor-dir": "core/vendor",
        "bin-dir": "bin"
    },
    "autoload": {
        "psr-4": {
            "Thelia\\": "core/lib/Thelia"
        },
        "psr-0": {
            "": "local/modules/"
        },
        "files": [
            "core/bootstrap.php"
        ]
    },
    "autoload-dev": {
        "psr-4": {
            "Thelia\\Tests\\" : "tests/phpunit/Thelia/Tests"
        }
    },
    "extra": {
        "branch-alias": {
            "dev-master": "2.3-dev"
        }
    }
}

C'est grave docteur ?
Merci !
Pierre

Offline


Non, ce n'est pas grave. Mais tu ne peux pas utiliser la procédure de mise à jour de thelia-project avec change-version.sh


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Bonjour,

Et donc la procédure à suivre c'est ..; FTP ? je croyais que Composer était la solution miracle à tous les maux de l'informatique ... :-)

Pierre

Offline


Procédure classique... wget remplacera avantageusement ftp, si tu as un accès ssh

Composer compose, comme son nom l'indique :-)


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2