THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 [RESOLU] Lenteur.......

(04-10-2017 12:14:08)


Bonjour,

Un petit souci sur un vieux thelia... c'est très lent...

En faisait un speed test, je me retrouve avec un temps d'attente énorme...  (Time To First Byte)

En regardant dans pma, j'obtiens ça :

932221Capturedcran1.jpg


Au niveau de ma config, j'ai bien le cache d'activé...

Une idée ..?


Aide les autres, ils t'aideront en retour.

Offline

Offline

#3 Re: [RESOLU] Lenteur.......

(04-10-2017 12:50:43)


V 1.5.4.1

Le site en question => https://tinyurl.com/y6vlgl2e

Des fois c'est très lent......... des fois c'est correct...

Last edited by Elyos (04-10-2017 12:53:49)


Aide les autres, ils t'aideront en retour.

Offline

#4 Re: [RESOLU] Lenteur.......

(04-10-2017 16:23:25)


Des fois c'est très lent......... des fois c'est correct

Plains-toi à ton hébergeur.

Il faudrait aussi vérifier que les tables sont correctement indexées (ce qui n'est pas le cas si tu as mis à jour ton Thelia depuis une 1.4, par exemple). Le gain apporté par des indexes pertinents est gigantesque.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#5 Re: [RESOLU] Lenteur.......

(05-10-2017 07:42:17)


A mon avis c'est lent quand y'a un peu plus de monde sur le site donc plus de connexions/requêtes simultanées à MySQL ...

Pour l'indexage, je peux les retrouver où ?!


Aide les autres, ils t'aideront en retour.

Offline

#6 Re: [RESOLU] Lenteur.......

(05-10-2017 08:04:56)


Il s'agit des index des tables de la base de données.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#7 Re: [RESOLU] Lenteur.......

(05-10-2017 08:15:03)


Oui oui.

Mais ceux mis en place à l'installation je les retrouve sur la dernière install de thelia ? (1.5.4.3)


Aide les autres, ils t'aideront en retour.

Offline

#8 Re: [RESOLU] Lenteur.......

(05-10-2017 08:48:22)


Les index sont définis dans le fichier install.thelia.sql


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#9 Re: [RESOLU] Lenteur.......

(05-10-2017 09:16:28)


Ouep wink

J'ai vérifié/modifié tous l'indexage... mais pas de "mieux" .... sad


Aide les autres, ils t'aideront en retour.

Offline

Offline

#11 Re: [RESOLU] Lenteur.......

(05-10-2017 09:34:14)


1&1 Unlimited Pro


Aide les autres, ils t'aideront en retour.

Offline

#12 Re: [RESOLU] Lenteur.......

(05-10-2017 09:56:51)


Bon, si c'est intermittent comme problème, c'est difficile d'établir un diagnostic. Tu utilises quels plugins sur ce site ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#13 Re: [RESOLU] Lenteur.......

(05-10-2017 10:03:48)


C'est bon je crois avoir trouvé le plugin qui merdouillait... trop de requêtes... je vais le modifier..

C'est un plugin maison qui permet de commander des produits selon certaines restrictions... (habilitation pour commander tel ou tel produit)


Aide les autres, ils t'aideront en retour.