THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 Configuration de TinyMCE

(21-02-2017 08:14:28)


Bonjour,

Lorsqu'on va dans la configuration du module TinyMCE et qu'on sauvegarde les modif, on a une erreur:
  Failed to update custom CSS file \"%file\". Please check this file or parent folder write permissions.

Mais on a beau changer les permissions d'écriture, rien n'y fait car l'écriture du fichier est désactivée par "if (1 ||" dans le controleur: thelia/local/modules/Tinymce/Controller/ConfigureController.php
Ligne 85: if (1 || false === file_put_contents($customCss, $data['custom_css'])) {

Est-ce volontaire ?
Merci !

Offline

#2 Re: Configuration de TinyMCE

(21-02-2017 08:26:47)


Bonjour,

c'est un bug, une correction a été proposée par roadster31
https://github.com/thelia/thelia/pull/2283

Offline

#3 Re: Configuration de TinyMCE

(21-02-2017 08:30:57)


Merci, c'est parfait.

Offline

#4 Re: Configuration de TinyMCE

(19-04-2017 09:53:50)


Bonjour,
J'ai bien mis à jour TinyMCE, le module est actif, les checkbox spécifiant les champs sont validé, la case à cocher "Afficher la barre de menu TinyMCE" est validée... mais je ne vois aucune Toolbar dans aucun des champs mentionnés, y-a-t'il une étape que j'aurais manqué ?

Offline

#5 Re: Configuration de TinyMCE

(19-04-2017 11:10:00)


Ce n'est pas clair.

Tu vois TinyMCE dans le back-office sur les champs "Description", mais sans la barre de menus, ou tu ne vois pas du tout TinyMCE ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#6 Re: Configuration de TinyMCE

(19-04-2017 11:27:53)


Pardon, je vais tenter d'éclaircir...
Le module est actif et configuré de façon standard mais aucune barre de menu n'est visible nulle part dans les éléments ciblés, c'est comme si TinyMCE n'était pas actif... Je n'ai pas rencontré d'anomalies a l'install et la mise à jour a bien supprimé le message d'erreur.
Je suis bien censé voir une barre et pouvoir enrichir les textes ?

Configuration TinyMCE

Offline

#7 Re: Configuration de TinyMCE

(19-04-2017 12:39:53)


Essaie de désactiver le module, puis de changer la variable "original_document_delivery_mode" de "symlink" à "copy", puis de réactiver le module.

Ca devrait marcher.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#8 Re: Configuration de TinyMCE

(20-04-2017 13:46:07)


Yes ! Parfait, ca corrige l'anomalie et TinyMCE est pleinement opérationnel, merci pour ton aide et ta réactivité !