THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 Upgrading 2.2.2 to 2.3.0

(24-04-2016 13:14:07)


Hi All,

A tried to upgarde to the latest version following this page: http://doc.thelia.net/en/documentation/ … st-version
I overwrite files
but when I visit /web/install/update.php page It said: "It seems that Thelia database is already up to date." ..... nothing happens...
Is this upgading method OK for the latest version?

Another issue:
When I tried to run php Thelia cache:clear in my vagrant box, I geting the following error():
$ sudo php Thelia cache:clear
#!/usr/bin/env php
PHP Fatal error:  Uncaught exception 'PDOException' with message 'SQLSTATE[42S22]: Column not found: 1054 Unknown column 'module_hook.TEMPLATES' in 'field list'' in /var/www/awesom
e/mysite/core/vendor/propel/propel/src/Propel/Runtime/Connection/StatementWrapper.php:196
Stack trace:
#0 /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/Connection/StatementWrapper.php(196): PDOStatement->execute(NULL)
#1 /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/Criteria.php(2436): Propel\Runtime\Connection\StatementWrapper->execute()
#2 /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php(1821): Propel\Runtime\ActiveQuery\Criteria->doSelect(Object(Propel\
Runtime\Connection\ConnectionWrapper))
#3 /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php(1000): Propel\Runtime\ActiveQuery\ModelCriteria->doSelect(Object(Pr
opel\Runtime\Connection\Connect in /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/Criteria.php on line 2442

Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[42S22]: Column not found: 1054 Unknown column 'module_hook.TEMPLATES' in 'field list'' in /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/Connection/StatementWrapper.php:196
Stack trace:
#0 /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/Connection/StatementWrapper.php(196): PDOStatement->execute(NULL)
#1 /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/Criteria.php(2436): Propel\Runtime\Connection\StatementWrapper->execute()
#2 /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php(1821): Propel\Runtime\ActiveQuery\Criteria->doSelect(Object(Propel\
Runtime\Connection\ConnectionWrapper))
#3 /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/ModelCriteria.php(1000): Propel\Runtime\ActiveQuery\ModelCriteria->doSelect(Object(Pr
opel\Runtime\Connection\Connect in /var/www/awesome/mysite/core/vendor/propel/propel/src/Propel/Runtime/ActiveQuery/Criteria.php on line 2442

Any Idea?
Is there an another way for upgrading the previous version?
Thanks

Last edited by akidur (24-04-2016 14:47:54)

Offline

#2 Re: Upgrading 2.2.2 to 2.3.0

(24-04-2016 17:21:20)


Could you please check your Thelia version in the database with the following SQL command ?

SELECT `value` FROM `config` WHERE name='thelia_version'

Could you also confirm that the file <your-thelia-root>/setup/update/sql/2.3.0.sql exists ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#3 Re: Upgrading 2.2.2 to 2.3.0

(25-04-2016 07:41:31)


roadster31 wrote:

Could you please check your Thelia version in the database with the following SQL command ?

SELECT `value` FROM `config` WHERE name='thelia_version'

Could you also confirm that the file <your-thelia-root>/setup/update/sql/2.3.0.sql exists ?

Thanks Roadster31,
I tried the process again from the backup and that worked second time smile.  I don't know what was the problem at first time(my tip is some problem with the file overwriting or vagrant file sync). Anyway Thank you for you quick reply, and kindly help.
s