THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


Bonsoir,

J'ai enchainer pas mal de problème avec l'install de thélia 2, bref je bute depuis maintenant un moment. Une fois l'installation terminée je ne peux me connecter au back office, j'ai une erreur 500.

J'ai du créer un php.ini dont voici le contenue (pour que l'installation se déroule correctement):
memory_limit = 256M
post_max_size = 20M
date.timezone = "Europe/Paris"
short_open_tag = off
magic_quotes_gpc = off

Avec ou sans les 3 dernières lignes j'ai le même résultat (pour l'erreur 500).

Je travail actuellement sur un hébergement mutualisé 1&1.

Donc je bute complètement et ne sais pas où chercher pour trouver un embryon de piste.
C'est pourquoi je vous demande votre avis smile

Merci par avance de vos réponses.

Last edited by trebor63 (28-08-2014 09:56:00)

Online

Offline


Exactement le genre d'embryon de piste que je cherchais merci. Je trouve que les logs d'acces et ftp dans le dossier log de l'hébergement, j'ai recherché sur internet comment y accéder mais je ne trouve pas.

Quelqu'un sait comment accéder aux logs apache chez 1&1? (j'ai envoyé un mail au service client aussi)

EDIT : j'avais pas vérifier mais ça déconne aussi avec d'autres fonctions comme enregistrer un nouvel utilisateur.

EDIT2 : Après des recherches plus approfondis dans le forum, j'ai un embryon de piste sur le rewriteengine :

Alexandre dans un autre fil de discussion wrote:

Note complémentaire :
Une fois l'install réalisée, on tombe sur une erreur 500.
C'est le htaccess qui se trouve dans le répertoire web qu'il faut modifier.
Dans mon cas j'ai une adresse comme ceci :
http://localhost:4656/thelia2_test_install
Je rajoute donc :
   
RewriteBase /thelia2_test_install/
Après
RewriteEngine On

Dans mon cas en partant de la racine c'est /health2/thelia_2.0.3 , je suppute que je dois mettre ça comme rewritebase non?
Enfin une dernière question qui peut sembler bête mais sait-on jamais j'ai peut être rien compris : le domaine faut bien que je le fasse pointer dans le dossier web hein?

Last edited by trebor63 (28-08-2014 07:57:55)

Online


Le domaine doit pointer vers le dossier /web (dans ton cas, ça doit être /thelia2_test_install/web). Dans ce cas, le RewriteBase n'est pas nécessaire.

Pour les logs d'erreur :

La FAQ 1&1 wrote:

The raw log files (in plain text) are saved in the logs/ folder within your web space


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Et voila ce que me sors le log de thélia si ça peut aider:

1: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/css/cf0b357.css
2: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/0185806.ico
3: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/7f8ec2b.png
4: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/b342cf6.gif
5: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/carousel/7706341.jpg
6: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/carousel/ec3ad61.jpg
7: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/carousel/220f621.jpg
8: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/d34e927.png
9: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/d34e927.png
10: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/d34e927.png
11: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/img/d34e927.png
12: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/js/libs/f789dce.js
13: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/js/bootstrap/8346315.js
14: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/js/plugins/bootbox/c20697f.js
15: DEBUG [AsseticAssetManager.php:processAsset()] {306} 2014-08-28 9:32:32: Asset destination full path: /homepages/28/d291717137/htdocs/health2/thelia_2.0.3/web/assets/frontOffice/default/0/js/271fb15.js

Pour la citation, elle viens d'un autre topic, moi c'est /health2/thelia_2.0.3/web du coup. Et si je coupe le rewriteengine je me retrouve avec une erreur 404.


Et pour le dossier logs j'ai déjà regardé mais ya que les logs access http/ftp/mail mais pas d'error_log.

Et merci pour les réponses moultement rapides smile

Last edited by trebor63 (28-08-2014 08:47:05)

Online


Tu devrais accéder à ta boutique en dev, avec index_dev.php (http://taboutique/index_dev.php/admin), ça te donnera sdirectement les messages d'erreur.

Pour que ça fonctionne, tu dois ajouter ton adresse IP à toi dans la liste qui figure dans le fiochier index_dev.php.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Humour quand tu nous tiens...
J'ai essayer cette technique d'index_dev et là ça fonctionne.
Du coup j'ai remarquer un truc :
si je fait http://laboutique/admin ça ne marche pas mais http://laboutique/index.php/admin fonctionne smile, l'embryon de piste grandit

EDIT:

du coup j'ai renommer index_dev en index pour tenter mais je me retrouve avec la même erreur

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Et si je met le rewriteengine sur Off dans le .htaccess je me retrouve avec une 404

Last edited by trebor63 (28-08-2014 09:47:09)

Offline


C'est bon, c'est moi qui suit un gros gland je pense je me suis pris la tête avec le rewriteengine alors qu'en faite avec un RewriteBase à / ça cuit.
Merci bien pour le coup de main.

Offline


Bonjour,

Je viens de passer un site fonctionnel de OVH à 1&1.
Impossible d'accéder au page ré-écrite comme /contact ou /admin et aucune page accessible si rewrite = 1
Par contre aucun problème d'accès à ces mêmes pages avec index_dev

L'ajout de RewriteBase /
a résolu le problème.

Je suppose que c'est propre à 1&1.
TREBOR63 merci pour le retour d'experience