THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


Bonjour,

Merci reg, c'est vrai il y ça à faire avec le plugin de compatibilité des templates. Mais j'avais cru comprendre qu'il y avait des modifs plus complexes à réaliser.


www.cascadefleurie.com

Offline


Tu pourrais peut etre tenter 1 mise a jour en local en dupliquant/sauvegardant l'existant pour mieux te rendre compte wink


le-bouquiniste.com                                                      tongue  plugin 1.4.x / 1.5   => valeurstock / Mailpaiement / formcontact

Offline


Bonjour,
je ne comprend pas
je viens de de migrer une version deja en ligne 1.4.3.1 sur mon seveur en local tout fonctionne php 5.3.20
je fait une mise a jour vers 1.5.4.2 et la
classes\CacheBase.class.php on line 104
j'ai en même temps installé en direct la version 1.5.4.2 qui fonctionne parfaitement ou est l’erreur ca fait au moins 15 fois que je re commence..
le répertoire classe de la 1.4 et la 1.5 sont différent
les droits pour la 1.4 se font dans le fichier cnx
dans la 1.5  se font dans config_thelia.php
quelqu'un a til une idée ?
car la je cale
Merci


Toujours en forme,
La différence entre le possible et l’impossible, c’est la volonté, et le  temps ...
Oui mais... ça c'est avec la meilleure volonté du Monde,
Et elle est, des fois, difficile à tenir

Offline


Bonjour,

Suivant les instructions de ce topics et avec l'aide du module, tout à été migré parfaitement en 1.5.2.

juste un soucis concernant les factures clients : elles ne sont plus visibles (alors que les bons de livraison oui), une piste ??

Deux questions complémentaires :

- est ce que je peux rester en 1.5.2, vu que les modules fonctionnent, cette version est stable ou vous me conseiller la 1.5.4 par exemple ?

- comme je l'ai dit j'ai utiliser le module de migration de 1.4 à 1.5 ; donc en toute logique, pour modifier mon template je garde les principe du 1.4 ?

Offline

Offline


page blanche !

en y regardant de plus près, le thélia 1.4 générait :

/client/pdf/facture.php?ref=C141022180718FAY


alors que celle en 1.5.2 :

/admin/livraison.php?ref=C1411191723000261


pour l'instant je n'ai touché aucun fichier

Offline


Page blanche = erreur PHP (je ne sais pas combien de fois j'ai tapé cette phrase sur ce forum smile )


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


thdebok wrote:

en y regardant de plus près, le thélia 1.4 générait :

/client/pdf/facture.php?ref=C141022180718FAY

alors que celle en 1.5.2 :

/admin/livraison.php?ref=C1411191723000261

Bon là j'étais fatigué, j'ai mélangé factures et livraison, bref.


J'ai virer et tourner sans trouver de solutions à cette page blanche.

Pouvez vous me confirmer que lors du process de mises à jour on ne touche pas le répertoire clients ?

Offline


pour voir l'erreur qui se produit, et donc comprendre ce qui se passe, je t'invite à regarder les logs d'erreur Apache, ou d'activer l'affichage des erreurs, display_errors = 1 dans ton php.ini.

Sans ça, on peut en causer des heures...


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


oui effectivement, donc au niveau des logs ça donne ça :

PHP Fatal error:  Cannot redeclare class Administrateur in /var/thelia/classes/Administrateur.class.php on line 94, referer: /thelia/admin1/commande_details.php?ref=C1411201412000263

Offline

Offline


lorsqu'on est sur le BO et que l'on clique sur "visualiser la facture au format pdf"

la ligne 94  de classes/Administrateur.class.php correspond à une "}"

Offline

Offline


ah, pourtant c'est l'erreur qui apparaît dans les logs d'apache lorsque j'essai d'afficher la facture en pdf !

Offline


lors d'une migration on ne touche pas le dossier client/ ou client/pdf ?

Offline


Ça dépend. Il y a peut être un plugin qui pose problème, essaie de les désactiver un par un.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


merci pour ton aide roadster, mais même en les désactivant 1 par 1, cela ne résout pas le soucis, aucun plugin d'activé et toujours cette page blanche avec les mêmes logs d'apache

Offline


Bon la troisième tentative était la bonne.

En fait j''ai remplacé à la main le dossier client/pdf par son équivalent dans la 5.2

Ouf smile