THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


Voici une procédure détaillée pour la mise à jour vers Thelia 1.5.2 :

Mise à jour de Thelia
------------------------

Thelia requiert un serveur web Apache 2, le langage PHP en version 5.3 minimum, et la base de données MySQL en version 5.

Assurez vous que l'environnement sur lequel vous souhaitez installer Thelia possède ces caractéristiques de base, sinon inutile d'essayer d'installer, ça ne marchera pas.

Assurez vous aussi que le Thelia que vous souhaitez mettre à jour est complet et fonctionne correctement, c'est à dire que vous pouvez y passer une commande avec succès. Une tentative de mise à jour sur une installation incomplète, bricolée, ou non- fonctionnelle ne pourra pas réussir.

Avant la mise à jour
-----------------------

Avant tout, procédez à une sauvegarde complète des fichiers de votre installation
actuelle de Thelia.

Procédez de même a une sauvegarde de votre base de données, en utilisant par
exemple la fonction 'export' de phpMyAdmin.

Procédure de mise à jour
-----------------------------

1) Si votre version actuelle est une version 1.4.x, veuillez renommer le fichier
   index.php à la racine de votre site en index.php.sauve.

   Si votre version actuelle est une version 1.5.x, inutile de procéder à cette
   manipulation.

2) Copiez l'intégralité des fichiers et répertoires présents dans la distribution,
   sur votre installation actuelle, en écrasant les fichiers et répertoires actuels.

   /!\ Assurez-vous de n'oublier aucun des fichiers de la distribution, tous
       doivent être copiés pour que la mise à jour puisse réussir.


   /!\ Utilisateurs de Mac OS X : Lors d'un replacement d'un répertoire, le finder
       supprime d'abord celui-ci avant de copier le nouveau. Soyez donc prudent
       avec votre fichier classes/Cnx.class.php lorsque vous écrasez le répertoire
       classes.

3) Renommez votre répertoire d'administration actuel (admin_xxxxxxx, ou
   le nom que vous lui avez choisi) en admin_xxxxxxx.sauve, par exemple

4) Renommez le répertoire 'admin' de la nouvelle installation, et donnez lui le
   nom du répertoire d'administration actuel: admin_xxxxxxx.

   Si par exemple votre répertoire d'admin actuel s'appelle admin_QZrT5S, vous
   devez maintenant avoir le répertoires suivants:

      admin_QZrT5S.sauve (votre répertoire admin actuel)
      admin_QZrT5S       (le répertoire admin de la nouvelle installation)

5) Pour lancer la mise à jour, faites pointer votre navigateur vers le répertoire
   d'installation:

      http://adresse_de_votre_serveur/install/

   Si vous avez installé Thelia  dans un sous-répertoire:

      http://adresse_de_votre_serveur/nom_du_sous_repertoire/install/


Une vidéo de démonstration de cette mise à jour est disponible ici:

   http://vimeo.com/24613269


Après la mise à jour
------------------------

Une fois la mise à jour réussie, vous pouvez supprimer les répertoires et fichiers
suivants:

   - client.orig
   - template.orig
   - l'ancien répertoire d'administration (admin_QZrT5S.sauve dans notre exemple)

Pour des raisons de sécurité, il vous faut supprimer (ou renommer) le répertoire
install.

/!\ Si vous venez de mettre à jour une version 1.4.x, il vous faut:

a) Remplacer le fichier index.php à la racine de votre site par la sauvegarde
   que vous en avez fait à l'étape 1)

b) Installer le plugin de compatibilité des templates 1.4, afin de pouvoir utiliser votre template
   actuel.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Bonjour tous

1) Copiez l'intégralité des fichiers et répertoires présents dans la distribution,
   sur votre installation actuelle, en écrasant les fichiers et répertoires actuels.

Pour le fichier index.php de la version 1.4.x faut écraser avec celui de la 1.5.2 ou pas.
Parce qu'aprés il est dit :

4) Si votre version actuelle est une version 1.4.x, veuillez renommer le fichier
   index.php à la racine de votre site en index.php.sauve.

mais théoriquement il est déjà écrasé.


thelia tout en images ==> http://thelia.griggione.fr/

Offline


Ca n'a d'importance que si on veut revenir en 1.4 après (et encore...). Donc on écrase sans hésiter.

Je corrige la procédure.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Bonjour roadster31

roadster31 wrote:

Je corrige la procédure.

Merci, j'ai corrigé aussi et fini ta procédure en image : MàJ thelia 1.5.2

Par contre tout à la fin, plus besoin du a) pour la 1.4, juste l'install du plugin non ?


thelia tout en images ==> http://thelia.griggione.fr/

Offline


Bonjour, En prévision de la mise à jour de la version 1.5.1 vers la 1.5.2, j'ai voulu faire une sauvegarde de la base de donnée avec le module Sauvegarde, mais j'obtiens le message d'erreur suivant :

Deprecated: Function ereg_replace() is deprecated in /home/.../plugins/sauvegarde/Sauvegarde.class.php on line 197

etc...

Quelle est la signification de cette erreur (qui n'a aucune conséquence sur le fonctionnement du site) ?

Merci,

Amicalement,

Thierry

Offline


Bonjour tsabot

C'est surement un plugin pour la v1.4.x
Le problème des contrib c'est que tout est mélangé, avant on avait les plugins pour 1.4 ou 1.5

roadster31 wrote:

Procédez de même a une sauvegarde de votre base de données, en utilisant par
exemple la fonction 'export' de phpMyAdmin.


thelia tout en images ==> http://thelia.griggione.fr/

Offline


Bonsoir,

Je viens de terminer ma mise à jour en suivant la procédure indiquée ci-dessous, tout c'est bien passé à un détail près :

Toutes mes commandes enregistrées depuis le 22 août à aujourd'hui 28 août n'apparaissent plus dans la rubrique commandes de l'espace privé de ma boutique.

Bizarre !
Quelle peut être l'origine de ce problème et comment le corriger ?

Merci pour votre aide,

Thierry

Offline


Si tu choisi "Toutes" dans le menu "Statut ' sur la gestion des commandes, tu les vois ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


roadster31 wrote:

Si tu choisi "Toutes" dans le menu "Statut ' sur la gestion des commandes, tu les vois ?

Ben pour le moment je ne vois plus rien.
Mon site est planté et affiche cette ligne d'erreur :

Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/www/.../www/classes/Baseobj.class.php on line 51

Offline


tsabot wrote:
roadster31 wrote:

Si tu choisi "Toutes" dans le menu "Statut ' sur la gestion des commandes, tu les vois ?

Ben pour le moment je ne vois plus rien.
Mon site est planté et affiche cette ligne d'erreur :

Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /home/www/.../www/classes/Baseobj.class.php on line 51

Est-ce que quelqu'un aurait une idée pour corriger cette ligne d'erreur ???

Merci par avance,

Offline


Tu n'es pas en PHP 5.3:

PHP 5.3 est requis pour Thelia 1.5.2. Une recherche sur le forum t'aurais donné la solution.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


roadster31 wrote:

Tu n'es pas en PHP 5.3:

PHP 5.3 est requis pour Thelia 1.5.2. Une recherche sur le forum t'aurais donné la solution.

Mais le problème est que je suis en php 5.3 comme on peut le lire sur la page d'administration de mon serveur :

/www/     5.3     actif     Configurer le PHP.ini
/www/     5.3     actif     Configurer le PHP.ini
/www/     5.3     actif     Configurer le PHP.ini

Je ne comprends donc pas cette erreur ???

Comment puis-je corriger, faut-il que je revienne à la version 1.5.1 ???

merci pour tes conseils,

Offline


Ha ? Pourtant on dirait *vraiment* que tu n'es pas en PHP 5.3

Fais donc un un phpinfo(); depuis un fichier situé au même niveau que index.php pour être sûr.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


tsabot wrote:
roadster31 wrote:

Tu n'es pas en PHP 5.3:

PHP 5.3 est requis pour Thelia 1.5.2. Une recherche sur le forum t'aurais donné la solution.

Mais le problème est que je suis en php 5.3 comme on peut le lire sur la page d'administration de mon serveur :

/www/     5.3     actif     Configurer le PHP.ini
/www/     5.3     actif     Configurer le PHP.ini
/www/     5.3     actif     Configurer le PHP.ini

Je ne comprends donc pas cette erreur ???

Comment puis-je corriger, faut-il que je revienne à la version 1.5.1 ???

merci pour tes conseils,

Bien qu'ayant php 5.3, la version 1.5.2 ne fonctionne pas correctement (voir ci-dessus). Bizarrement le site fonctionne parfois très bien pendant quelques minutes avant de nouveau d'afficher l'erreur ci-dessus et d'être inaccessible.

Faut-il que je revienne à la version 1.5.1 pour retrouver un site qui fonctionne normalement ???

Merci pour vos conseils,

Thierry

Offline


roadster31 wrote:

Ha ? Pourtant on dirait *vraiment* que tu n'es pas en PHP 5.3

Fais donc un un phpinfo(); depuis un fichier situé au même niveau que index.php pour être sûr.

effectivement le phpinfo semble confirmer que je suis en php 5.2 alors que mon hébergeur affiche php 5.3 sur la page d'administration de mon serveur !!!

Voici le résultat du phpinfo :

PHP Version 5.2.17

REDIRECT_HANDLER     php-5.2
ORIG_SCRIPT_NAME     /php-exec/php-5.2.exec
ORIG_SCRIPT_NAME     /php-exec/php-5.2.exec
_SERVER["REDIRECT_HANDLER"]    php-5.2
_SERVER["_"]    /usr/local/php-5.2/bin/php-cgi
_SERVER["ORIG_SCRIPT_FILENAME"]    /home/php/php-5.2.exec
_SERVER["ORIG_SCRIPT_NAME"]    /php-exec/php-5.2.exec

Qu'en penses-tu ?

Last edited by tsabot (28-08-2012 19:34:56)

Offline


Je pense qu'il faut que tu configures ton serveur pour qu'il utilise PHP 5.3 au lieu de 5.2 smile

Après comment, ça dépend de plein de choses, à toi de voir avec ton hébergeur.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Merci pour ta réponse.

En fait, avant de faire la mise à jour j'avais déjà configuré le serveur pour qu'il soit compatible php 5.3. Pour cela j'avais suivi la procédure indiquée par mon hébergeur. De fait, sur la page principale du serveur, dans les caractéristiques de ce dernier, il était bien affiché : serveur php 5.3... mais en réalité il était bien toujours en php 5.2.17. J'ai demandé une explication à mon hébergeur et qu'il fasse le nécessaire lui-même pour passer le serveur en php 5.3.

En attendant, je suis revenu à la version 1.5.1 de Thélia.

Bonne journée,

Amicalement,

TS

Offline


roadster31 wrote:

Si tu choisi "Toutes" dans le menu "Statut ' sur la gestion des commandes, tu les vois ?

Pour info, en repassant sur la version 1.5.1, j'ai retrouvé toutes mes commandes disparues lors du passage à la version 1.5.2 (et pourtant le menu "statut" affichait bien "Toutes").

Offline

Offline


roadster31 wrote:

Ca sent la config pas bien maitrisée, ça...

bon voilà, ce matin, mon hébergeur a basculé le site sur un serveur php 5.3.12.

Mais je me pose toujours une question : est-ce le problème de version de php qui peut expliquer la disparition de toutes les commandes passées entre le 21 août et le 28 août (elles sont toutes revenues sur Thélia 1.5.1) ?

Merci,

Amicalement,

TS

Offline


Gros souci avec un portage 1.44 vers 1.52, j'ai effectué la mise à jour en local (Mamp) en suivant la procédure et ça c'est plutôt bien passé.

Maintenant j'en suis à porter cette version sur un espace de dev visible par le client et là ça se gâte.

Le portage du site local en dev web merde, j'ai des message d'erreur PHP, j'ai essayé de faire un clean install en 1.52 puis ajout de ma BDD ça repart en vrac (erreur PHP) j'ai eu des souci de droits qui semblent résoluas mais en refaisant le portage de la 1.44 sur le site de dev puis la procédure de mise à jour je reste sur l'écran de mise à jour et aucune procédure n'est lancé.

Je subodore un souci (php + droits ou php seul) dans la configuration du serveur de dev mais où cela peut coincer ?

Merci de vos lumières.

Offline


Sur ton hébergement cible, vérifie que tu est en php 5.3

j'ai des message d'erreur PHP

Lesquels ? Si tu ne les donnes pas, on ne PEUT PAS t'aider !


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Bon, on vient de tout refaire tranquille avec mon partenaire hébergeur… et la mise à jour fonctionne correctement (pas encore fait le tour de tout)… donc… je pense que j'ai fait une fausse manip… quelque part… certainement… hein… bon… ouais… je crois… LOL.

Merci de ton attention Roadster. :-)

Offline


Bonjour,

Je voudrais basculer d'un Thelia 1.4.3.1 vers 1.5.3.3 et en regardant la procédure détaillée de Roadster31, je vois qu'il n'est plus question d'avoir besoin d'un outil de migration tel que celui qui était sous forme d'un tutoriel PDF pour basculer de 1.4.x vers 1.5.x quand était apparu 1.5.0.

Cela veut-il dire que tout s'est simplifié pour ne devenir qu'une "bête" mise à jour, y compris pour les plugins?

Merci de me répondre avant que je ne me lance dans des problèmes !


www.cascadefleurie.com

Offline


Encorejeune wrote:

Je voudrais basculer d'un Thelia 1.4.3.1 vers 1.5.3.3

cela implique aussi que tu modifies toutes les pages de ton template ANSI=>UTF-8 comme si tu migrais vers 1.5 wink


le-bouquiniste.com                                                      tongue  plugin 1.4.x / 1.5   => valeurstock / Mailpaiement / formcontact