THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 Pb page accueil du BO

(04-04-2022 16:23:00)


Bonjour,
je me rends compte que ma page d'accueil s'amuse à m'afficher la page d'accueil du front.
Le template du BO est default, celui d'origine.

Dans le fichier templates/backOffice/default/home.html, ça enleve le front et un bout des statistiques si je supprime :

            <div class="row">
                {hookblock name="home.block" fields="id,title,content,class"}
                {forhook rel="home.block"}
                <div class="{if $class}{$class}{else}col-md-4{/if}">
                    <div {if $id}id="{$id}"{/if} class="general-block-decorator">
                        {if $title}<div class="title title-without-tabs">{$title}</div>{/if}
                        {$content nofilter}
                    </div>
                </div>
                {/forhook}
                {/hookblock}
            </div>

C'est certainement pas une bonne solution, je ne vois pas d'ou ça vient, ni ce qu'il faudrait faire.
Ca me fait bizzare de voir un mélange du front et du back ..

Merci d'avance

Online

#2 Re: Pb page accueil du BO

(04-04-2022 20:35:32)


Il doit y avoir un problème de routes quelque part.
Tu as vidé le cache ?


OpenStudio Toulouse

Offline

#3 Re: Pb page accueil du BO

(05-04-2022 10:18:52)


Le cache oui, c'est quasiment un réflexe maintenant wink
Par acquis de conscience, je viens de retourner le vider, rien de changé.

Pour les routes, c'est possible mais je ne vois pas de quel coté il faudrait que j'aille voir, un module ? ou autre ?

J'avais pensé à un problème de javascript, car au début du chargement la page s'affiche correctement, puis au bout de 2/3 secondes,
elle devient pâle et certains élements sont décalés.

Capture-d-cran-2022-04-05-11-15-07.png

Online

#4 Re: Pb page accueil du BO

(05-04-2022 10:50:59)


au début du chargement la page s'affiche correctement, puis au bout de 2/3 secondes, elle devient pâle et certains élements sont décalés.

C'est parce que la home est chargée et perturbe pas mal le DOM.

Observe ces qui est chargé dans l'onglet "Réseau" de la console du navigateur, pour voir quelle requête retourne la home page.


OpenStudio Toulouse

Offline

#5 Re: Pb page accueil du BO

(07-04-2022 11:32:50)


Bon à force de jouer avec la console et l'onglet réseau, et de désactiver des modules.
Dans les modules, j'ai fini par voir le HookAdminHome, dans lequel j'ai coché :

Enabled default Home Stats
Enabled Sales Statistics
Enabled Info

et l'affichage de la home se fait correctement.

Par contre, si je coche, "Enabled News Check", le problème revient.

A croire que mon site n'aime pas les news de thelia .. Moi je les voudrait bien, mais bon c'est pas si grave.
Ceci le dysfonctionnement ne m'est pas compréhensible.

Online

#6 Re: Pb page accueil du BO

(07-04-2022 13:57:35)


Je comprends mieux.

Il doit se produire une erreur lors de la récupération du fil des news sur tweeter, et en conséquence c'est la page d'erreur complète de Thelia qui s'affiche dans le cadre des news.

Quant au pourquoi de l'erreur sur le fil d'actu, il faudrait enquêter sur ta machine.


OpenStudio Toulouse

Offline

#7 Re: Pb page accueil du BO

(09-04-2022 11:36:26)


Bon l'important c'est que ça marche comme ça.
Je ne vais pas avoir le temps de jouer au détective wink

Merci de m'avoir mis sur la piste