THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


Bonjour,

Je développe en mode dev via index_dev.php et le serveur PHP paramétré pour afficher les erreurs. Je peux donc visualiser sans problème les messages d'erreurs liés au développements d'un module par exemple.

Cependant, je n'ai pas les messages d'erreur lié à l'appel d'une route inexistante ou d'autres problèmes du genre. J'ai une page blanche ou mon template complétement destructuré.

Je précise qu'il s'agit ici de templates sur-mesure, pas de problème avec le template par défaut.

Que dois-je mettre dans la page error.html pour visualiser cela ?
Je suppose que dans la page par défaut, l'erreur s'affiche dans ce bloc :

{block name="body-class"}page-error{/block}

Je suppose également qu'il y a un module/hook qui affiche l'erreur dans ce bloc ?

Offline


Je suppose que dans la page par défaut, l'erreur s'affiche dans ce bloc :

{block name="body-class"}page-error{/block}

Je suppose également qu'il y a un module/hook qui affiche l'erreur dans ce bloc ?

Non, le bloc "body-class" permet juste d'indiquer la classe CSS à appliquer au body, comme on peut le voir dans layoiut.tpl :

<body class="{block name="body-class"}{/block}" itemscope itemtype="http://schema.org/WebPage">

Cf. la doc Smarty : https://www.smarty.net/docs/en/language … .block.tpl

Il n'y a pas non plus de hook pour afficher l'erreur, en dev c'est Symfony\Component\Debug\ExceptionHandler qui se charge de l'affichage.

Par ailleurs, en dev comme en prod, appeler une route inexistante provoque une erreur 404. Si ton template est "déstructuré", c'est que le message d'erreur est affiché quelque part à l'intérieur d'une balise et fiche en l'air le DOM. Regarde le code source de la page.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2