THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 [SOLVED] Tinymce Thélia 2.3

(05-01-2018 10:55:23)


Bonjour,

j'ai installé Module TinyMCE WYSIWYG editor 2.4.0-alpha1 dans thélia 2.3.4
j'ai une probléme dans l'insertion de l'image ,
L'image ne s'affiche pas dans la zone de texte,
juste un cadre noir s'affiche

Merci

Last edited by Elif (11-01-2018 08:17:31)

Offline


Quelle est l'URL de l'image qui est générée dans la zone de texte ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


http://localhost:80/ProjetThelia/web/media/upload/logo.jpg

Offline

Offline


L'image est enregistré sous  bureau
C:\Users\AAAA\Desktop\logo.jpg

Offline

Offline


clic sur l'icone Image
==>fenêtre inséré / modifier image s'affiche : 
            -Clic pour choisir la Source
==>fenêtre Explorateur de fichiers s'affiche
            -Clic sur + (envoyer un fichier)
                           - clic Drop files to upload
                           -choisir l'image
                           - ok
            - Revenir à la liste des fichiers
            -Clic sur L'image

Offline


Bien.

Donc si tu mets http://localhost:80/ProjetThelia/web/media/upload/logo.jpg dans la barre d'adresse du navigateur, ça donne quoi ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


un petit cadre noir

et si je clic sur l'icone Prévisualiser
s'affiche rien , ni cadre ,ni image

Offline


****    http://localhost:80/ProjetThelia/web/media/upload/logo.jpg dans la barre d'adresse du navigateur,

==> Not Found
The requested URL /ProjetThelia/web/media/upload/logo.jpg  was not found on this server.

Offline


Et avec http://localhost:80/web/media/upload/logo.jpg ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Not Found
The requested URL /web/media/upload/logo.jpg was not found on this server.

Offline


Trouve l'URL correcte pour accéder à cette image, qui devrait se trouver dans C:\...\ProjetThelia\web\media\upload\logo.jpg, ça aiderait à déterminer le problème.

Déjà c'est quoi l'URL de base de ta boutique, et c'est quoi le chemin sur disque de ta boutique ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Bonjour,

URL correcte pour accéder à cette image :  C:\Users\AAAA\Desktop\logo.jpg
                                                                      D:\wamp64\www\ProjetThelia\web\media\upload\logo.jpg
l'URL de base : D:\wamp64\bin\mysql\mysql5.7.19\data\theliadb
le chemin sur disque du boutique :  D:\wamp64\www\ProjetThelia

Offline


l'URL de base : D:\wamp64\bin\mysql\mysql5.7.19\data\theliadb

Heu... Ça, c'est le chemin d'accès au répertoire qui contient les fichiers de la base de données MySQL de ta boutique. Ça n'a rien à voir avec l'URL de base.

Tu confonds URL (htp://...) et chemin d'accès sur disque (C:\...)

Pour faire simple, l'URL de base de ta boutique c'est ce que tu tapes dans la barre d'adresse du navigateur pour accéder à ton site.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Interface Client : http://localhost:80/ProjetThelia/web/
Interface Admin : http://localhost:80/ProjetThelia/web/admin

Offline


386587Explorateur.jpg
145279Image.jpg

Last edited by Elif (06-01-2018 10:46:24)

Offline


L'URL de l'image devrait donc être http://localhost:80/ProjetThelia/web/media/upload/logo.jpg

L'image se trouve bien dans le dossier D:\wamp64\www\ProjetThelia\web\media\upload, et est bien un image JPEG correcte ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Bonjour,

L'URL de l'image devrait donc être http://localhost:80/ProjetThelia/web/media/upload/logo.jpg

L'image se trouve bien dans le dossier D:\wamp64\www\ProjetThelia\web\media\upload, et est bien un image JPEG correcte ?

oui, L'image se trouve  dans le dossier D:\wamp64\www\ProjetThelia\web\media\upload
oui, c'est une image JPEG correcte

Offline


Quand tu tapes http://localhost:80/ProjetThelia/web/media/upload/logo.jpg dans la barre d'adresse de ton navigateur, tu vois l'image ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Quand tu tapes http://localhost:80/ProjetThelia/web/media/upload/logo.jpg dans la barre d'adresse de ton navigateur, tu vois l'image ?

oui,

Offline


Bon, alors d'après le post #3, où tu dis que l'URL de l'image est  http://localhost:80/ProjetThelia/web/media/upload/logo.jpg, ça devrait fonctionner parfaitement.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


le problème persiste toujours :
si je télécharge une nouvelle image

Offline


Peut être une piste de solution car je viens de me rendre compte que j'ai le même pb.

Mon image est bien uploadée dans /public_html/web/media/upload est accessible via http://domain.tld/web/media/upload/Tulips.jpg
Mais quand je fais un clic droit dans l'explorateur de fichier TinyMCE sur le thumbnail de l'image et que je fais afficher l'URL j'obtiens http://domain.tld/media/upload/Tulips.jpg  et non pas http://domain.tld/web/media/upload/Tulips.jpg

Or le DocumentRoot de mon vhost est "/home/www/xxx/public_html" et pas "/home/www/xxx/public_html/web"
J'aurai la certitude demain car j'ai demandé à mon hébergeur de réaliser la modification du vhost

Offline


Je viens de vérifier la valeur de ma variable url_site dans les paramètres de configuration (admin/configuration/variables) et elle avait pour valeur http://domain.tld !
Après tests cela fonctionne pour moi si je mets http://domain.tld/web ou bien que je supprime tout simplement la valeur