THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


Bonjour la communauté,

j'ai fait un petit module pour mettre les éléments de réassurance.
j'ai déclarer le css dans le hook event qui se charge bien avec le module sur la page produit.
Mais en mode quick-view le template et les langues se chargent bien, mais pas le css.

Last edited by fredodefrance (02-06-2017 13:27:34)


C'est en faisant qu'on apprends.

Offline


j'ai déclarer le css dans le hook event

C'est à dire ? Qu'as-tu écrit exactement ?


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


le quickview affiche que la partie qui est entre <article> si j'ai bon souvenir

Offline


Peut être que le stylesheet est déclaré trop bas.

L'extrait de config.xml

    <hooks>
        <hook id="reinsurance.hook.front">
            <tag name="hook.event_listener" event="product.details-bottom" templates="render:reinsurance.html" />
            <tag name="hook.event_listener" event="product.stylesheet" type="front" active="1" templates="css:assets/css/reinsurance.css" />
        </hook>
    </hooks>


C'est en faisant qu'on apprends.

Offline


Résolu.

Changé la déclaration dans le config.xml.
Déclaré dans main.stylesheet au lieu de product.stylesheet.
        <hook id="reinsurance.hook.front">
            <tag name="hook.event_listener" event="product.details-bottom" templates="render:reinsurance.html" />
            <tag name="hook.event_listener" event="main.stylesheet" templates="css:assets/css/reinsurance.css" />
        </hook>


C'est en faisant qu'on apprends.