THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 Pb image module assets

(09-03-2016 18:00:38)


Bonjour,

je souhaite afficher tout simplement une image qui se trouve dans les dossier templates de mon module sous FrontOffice/default/assets/img/fabricants/90/BMW.png

Je fais donc ceci dans ma view :

<img width="100" height="100" src="{image file='assets/img/fabricants/90/BMW.png'}" alt="test" />

Mais j'obtiens une erreur "Failed to find asset source file assets\img\fabricants\90\BMW.png"

je ne comprend pas pourtant les fichiers sont bien dans le bon dossier j'ai vidé le cache et tout.

Merci de votre aide.

Cordialement;

Last edited by Shiness (09-03-2016 18:02:58)

Offline

#2 Re: Pb image module assets

(09-03-2016 19:16:18)


Si tu obtiens cette erreur, c'est que l'image n'a pas été trouvée. Elle ne se trouve donc pas à la bonne place, ou alors ne porte pas le nom que tu attends.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline

#3 Re: Pb image module assets

(10-03-2016 09:44:18)


Non j'ai pourtant bien vérifié tout est ok...

Pourtant si je met:

<img src="{image file='assets/dist/img/logo-final.png'}" alt="{$store_name}">

Cela récupère bien l'image au niveau du template principal, mais au niveau du module cela ne fonctionne pas.

Last edited by Shiness (10-03-2016 09:53:06)

Offline

#4 Re: Pb image module assets

(28-10-2017 00:27:26)


Bonjour la communauté.

Ce sujet date un peu.

Je viens d'avoir ce problème au niveau d'un module.
Résolu comme cela.
<img src="{image file='assets/img/monimage.png' source='MonModule'}" alt="{intl l="Ma désignation" d= "monmodule.fo.default"}">
Si cela peut aider.


C'est en faisant qu'on apprends.