THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline


J'ai quelques problemes pour modifier mon style
tout d'abord j'utilise ce theme https://github.com/thelia-templates/interiorz
j'ai bien suivi la doc et change tout , je vois donc bien le nouveau template

le probleme est quand j'essaye de faire des modifs
voila ce que j'ai quand j'essaye dexecuter grunt ds le dossier : templates/frontOffice/interiorz/
http://www.awesomescreenshot.com/image/ … 7cf0b0fde6

J'ai aussi essaye l'autre solution et modifie ca ds ma page layout.tpl
http://www.awesomescreenshot.com/image/ … 6f33183dac

puis reloader la page mais sans succes
http://www.awesomescreenshot.com/image/ … 3bad22f513

En esperant trouve un peu d'aide ici
D'avance merci

PS : J'aimerais beaucoup utiliser Grunt plutot que la 2e solution

Offline


On dirait qu'il y a un problème avec la tache imagemin : https://github.com/gruntjs/grunt-contri … issues/330

Le plus simple serait de ne pas exécuter cette tache imagemin.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Ok merci j'ai suivi cette solution et ca marche
https://github.com/gruntjs/grunt-contri … /328/files

maintenant quand je change quelque chose je peux le voir ds mon terminal
http://www.awesomescreenshot.com/image/ … 4a17defd34

Mais pas encore sur le site
dois-je changer quelque chose ds ma page layout.tpl ?
Pour l'instant c comme ca

    {stylesheets file='assets/dist/css/thelia.min.css'}
        <link rel="stylesheet" href="{$asset_url}">
    {/stylesheets}

le fichier que je modifie est celui la
`templates/frontOffice/default/layout.tpl`

Offline


Si tu bosses en remote, assure toi que le fichier généré est bien uploadé sur ton serveur.

Si tu es en local, regardes où est le css généré (tache cssmin), c'est celui-là que tu dois utiliser.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


Bon j'ai limpression que j'y suis presque , grunt is running
j'ai change la ligne des assets ds layout.tpl a

 {stylesheets file='assets/src/css/thelia.css' template="interiorz"} 

donc maintenant si je change une couleur ds mon ficher .less cela change automatiquement ca ds mon thelia.css cki met a jour le site
voila mon probleme
mes assets images me donne des 404 , j'ai l'impression que je dois changer le chemin des images mais je ne sais pas trop ou

 http://localhost:8888/thelia/web/assets/frontOffice/interiorz/template-assets/assets/src/img/help-image.png Failed to load resource: the server responded with a status of 404 (Not Found) 

ce fichier est dispo par example mais a cette adresse /DIST/ a la place de /SRC/

 http://localhost:8888/thelia/web/assets/frontOffice/interiorz/template-assets/assets/dist/img/help-image.png 

A tout hasard Avez vous un chat en plus du forum ?

D'avance merci pour votre aide

Offline


Une idee ROADSTER31 ?

Last edited by lea (21-01-2016 22:24:44)

Offline

Offline


Elles sont ds ce repertoire : thelia/web/assets/frontOffice/interiorz/template-assets/assets/dist/img/

Mais le site essaie de loader a partir du /src repertoire
thelia/web/assets/frontOffice/interiorz/template-assets/assets/src/img/

Offline


Alors "le site" se trompe. Corrige le. Il doit sans doute y avoir des {image file="assets/src/img/pouetpouet.gif"} qui trainent.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2