THELIA Forum

Welcome to the THELIA support and discusssion forum

Offline

#1 Problème Atos / Scellius

(27-10-2007 11:52:48)


Bonjour,

Je cherche à faire fonctionner Thelia avec le système de paiement Scellius de la banque postale. C'est simplement le système Atos. J'ai tout paramétré conformément au fichier README, mais j'obtiens systématiquement le message "executable request non trouve bin/request". Un file_exists inséré avant and paiement.php me montre que le fichier request est bien vu. Mais son exec ne renvoie aucun résultat.

Quelqu'un a une idée?

Par avance merci.

A+.

Scapin

  • yoan
  • Cofondateur Thelia

Offline


Tu as copié le binaire request et response fourni par la banque dans le répertoire bin ?


http://yoandemacedo.com

Cofondateur de la solution Thelia 1.x

Offline


Oui, request et response sont dans bin.

Etant donné les erreurs affichées, j'ai même essayé successivement avec les 3 versions différentes des 2 binaires. Ca ne change absolument rien sad

S.

Offline


L'erreur stupide: il manquait les droits d'exécution sur request et response. Désolé d'avoir encombré le forum sad
Toutes mes excuses.
S.

  • yoan
  • Cofondateur Thelia

Offline


pas de soucis


http://yoandemacedo.com

Cofondateur de la solution Thelia 1.x

Offline


bonjour

je me permet ce (gros) deterrage car j'ai une question proche.
J'utilise actuellement un plugin Atos pour paiement avec le credit agricole.
Je souhaite passer à la la banque postale via Scellius.

Il suffirait simplement de changer les binaires pour que cela fonctionne ?

Merci d'avance

Offline


Tous les modules Atos utilisent les binaires Atos.

Pour tout système de paiement basé sur Atos, tu peux donc installer le plugin Atos de Thelia.


CQFDev | Sites, boutiques, modules, développement et intégration pour Thelia 1 et 2

Offline


d'accord
il est déjà installé (et fonctionne actuellement avec un paiement credit agricole)
donc il me suffira apparemment de changer les binaires.
merci

Offline


Bonjour, je me permet de poster ici car j'ai un soucis avec le request d' atos.
Je suis sous thélia 1.5.4.3, hébergé chez easy hébergement, j'ai testé les bin fourni par mercanet, celui de l'hébergeur aussi, ceux du forum 32/64 bit, le chmod 755/715/777/...(tous quoi), transfert en binaire sous filezilla, tous les chemins d'accés possible, j'ai vue sur cette page http://thelia.net/forum/viewtopic.php?id=1965 de passer en safe_mode off dans le php.ini de l'hébergeur je ne l'ai pas trouvé.

Notice: Undefined offset: 1 in /public_html/www/client/plugins/atos/paiement.php on line 64

Notice: Undefined offset: 2 in /public_html/www/client/plugins/atos/paiement.php on line 65

Notice: Undefined offset: 3 in /public_html/www/client/plugins/atos/paiement.php on line 66

erreur appel request

executable request non trouve bin/request 

C'est la seule chose qui manque au lancement du site hmm donc si vous pouvez m'aider ça serait extraordinaire je peux fournir les accès du ftp en mp si necessaire car je m'arrache les cheveux sur ça, même si il n'y a aucune solution, une réponse pour me dire que c'est pas possible sera toujours la bienvenue.
Merci à tous.

édit: bon j'ai réussi à avancé sur mon problème c'était très bète comme erreur le chmod il faut coché la case pour tout les sous dossier en 755 dans la récursion de filezilla -_- ensuite les certificat fourni il faut enlever l'extension .php à la fin.
Maintenant je vais contacter mercanet car j'ai une erreur de certificat api (je suis pas rendu hmm ) :

Erreur appel API de paiement.



message erreur :
API ERROR
Error reading certificate data at line (E0459F42FCF26F53D601261263885E7790E52DB8B555FCE8C090D7478738EC529F ) 

Voila c'est résolu, il fallait télécharger la version classique du certificat fourni par mercanet. C'est moi ou le forum pour Thélia 1 est mort ?

Last edited by Yzzo (23-10-2015 10:08:42)